1

I got an issue on backend, */catalog_product/edit after applying successfully the patch SUPEE-8788.

The error "Uncaught ReferenceError: Uploader is not defined" is returned.

The uploader buttons are displayed but don't work (because of this JS error I guess).

Is someone got the same error? If yes, how did you fixed it?

EDIT: This initial issue is now fixed.


No js merge is disabled (I'm working locally).

But I've found the problem. The cause was: me ':)

I ran the PATCH on my distant server, then retrieve all the updated ressources locally.

I've just forgot to take the folder /js/mage/adminhtml/uploader

So now the uploader is opening the windows for file selecting.

BUT, when I click on "upload files", the uploader seems working fine, "complete" message is displayed.

BUT no image seems really uploaded (the file is not added to the product images list).

4

I had the same error:

I got an issue on backend, */catalog_product/edit after applying successfully the patch SUPEE-8788. The error "Uncaught ReferenceError: Uploader is not defined" is returned.

I checked that the SWF files were there and the js files were there as listed in this post but was still getting the error. These are the steps I took to mend it for my installations.

  1. I checked that Merge JavaScript Files was off in system -> configuration -> developer
  2. I went into General -> Design and made sure that themes -> default was set to "default" instead of the custom theme name. I think this may have been the cause of the issue for me, perhaps it was looking for the files in the wrong place?
  3. I emptied the cache in system -> cache managment -> select all -> refresh
  4. I rebuilt the indexes (this wouldn't have made any difference but I did it)
  5. I emptied the local browser cache.
  6. I relogged in and it all worked.

YMMV but I hope that helps someone, I wasted a couple of hours on this.

Kind regards

  • check swf files are here: /skin/adminhtml/default/default/media – Shyam Krishna Sreekumar Oct 21 '16 at 11:19
  • Merge js files was the fix for me, thanks! – Marcel Sep 28 '17 at 9:40
1

I had the same error. The problem turned out to be that I had a customized version of app/design/adminhtml/default/default/layout/main.xml. I merged the changes from the patch into my customized version and refreshed the Magento Caches. That worked for me.

1

I ran into the same problem. Turned out an extension made IE run in IE-8 compatibility mode.

Look for some code like <meta http-equiv="X-UA-Compatible" content="IE=xxx" /> in your HTML (xxx is any IE version, in my case 8).

If you encounter this, you probably have the same issue. Try updating the module or fix the undelying problem.

1

in my case

js/mage/adminhtml/uploader/instance.js was missing.

I downloaded a fresh magento 1.7.0.2 installation and upload to the mine.

0
  1. Flush and Refresh Magento Cache.
  2. Try re indexing.
  3. check below swf files are exists in media folder, -flex.swf -uploaderSingle.swf -uploader.swf

Path to check :skin/adminhtml/default/default/media/

  1. lastly clear browser cache and check again.
  • Why my suggestion edit is rejected? – Teja Bhagavan Kollepara Oct 18 '16 at 9:10
  • Step 3, should swf the files exist or not exist? What should one do if they are found/not found? – Wes Oct 18 '16 at 22:07
  • All those 4 steps are done. No joy, still having the same issue ?? anyone fixed this issue. please help me. i am ran in 1.9.1.0 – Crock Oct 20 '16 at 4:51
0

Is your merge JS enable in your site? So please disable it for admin and that will works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.