0

I need to install one minor version down from the current 2.1.2 using Composer.

I try:

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition 2.1.0 /home/m2track/public_html

However I get : " Could not parse version constraint /home/m2track/public_html: Invalid version string "/home/m2track/public_html" as an error.

What is the correct syntax to install 2.1.0 or 2.1.1 using composer ?

5

Try with:

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition=2.1.0 /your/destionation/path
  • don't know why the other answer is set as correct. With yours I was able to install an older version. With the other I was getting "could not parse version constraint" – Daniel Dimitrov Feb 12 '17 at 17:20
  • take out the **'s , was meant to bold the version #. I just tried it again, and it works. I'll edit my answer though to remove that. – Spyrule Sep 19 '17 at 4:46
2

Turns out I had the version in the wrong place:

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition /home/m2track/public_html 2.1.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.