2

I am trying to install the security patch 8788 but I get some errors.

patching file js/mage/adminhtml/product.js
patching file js/mage/adminhtml/uploader/instance.js
can't find file to patch at input line 5810
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git lib/Unserialize/Parser.php lib/Unserialize/Parser.php
|index 423902a..2c01684 100644
|--- lib/Unserialize/Parser.php
|+++ lib/Unserialize/Parser.php
--------------------------
File to patch: 
Skip this patch? [y] 
Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 5822
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git lib/Unserialize/Reader/Arr.php lib/Unserialize/Reader/Arr.php
|index caa979e..cd37804 100644
|--- lib/Unserialize/Reader/Arr.php
|+++ lib/Unserialize/Reader/Arr.php
--------------------------
File to patch: 
Skip this patch? [y] 
Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 5838
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git lib/Unserialize/Reader/ArrValue.php lib/Unserialize/Reader/ArrValue.php
|index d2a4937..c6c0221 100644
|--- lib/Unserialize/Reader/ArrValue.php
|+++ lib/Unserialize/Reader/ArrValue.php
--------------------------
File to patch: 

The whole lib/Unserialize folder does not exists. The shop of my client is running Magento 1.8.1.0 I have another client with the exact same thing, I also downloaded the correct file. And tried earlier patches too to see if some of them maybe created those folders but I could not really find anything. I would appreciate if somebody can point me in the right direction or has solved this problem before.

  • 1
    Looks like patch 6788 was not installed properly – Wesley Oct 18 '16 at 1:42
  • Great advice @wesley. Adding 6788 before 8788 worked for me, thanks. Note that it was for a 1.8.0.0 site, not 1.8.0.1, but that shouldn't matter. – TunaMaxx Oct 18 '16 at 23:29
1

Just to make it an actual answer, I'll copy the comment with the answer here on behalf of the OP.

To make sure that SUPEE-8788 works properly, you should have installed some of the earlier patches. In this case, SUPEE-6788 wasn't installed. After installing that one before installing SUPEE-8788, the issue was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.