6

As we all know, there is some issue in security patch SUPEE 8788, so magento has released its new security patch SUPEE 8788 v2. I am wondering there is anything new for the after magento 1.8 or it is the patch for previous versions.

And also want to know what could be possible error and what precaution we need to take care before installing this patch?

5

SUPEE 8788 V2 fixes the following problems introduced by SUPEE 8788 V1:

  • conflict with 1533 patch
  • conflict with 3941 patch
  • Unsupported data type N error in /lib/Unserialize/Reader/ArrValue.php in 1.9.1.0 and possibly earlier versions

If you apply the patch V2 don't forget to follow this procedure:

  • revert SUPEE-8788 v1
  • revert SUPEE-1533 (if installed)
  • install SUPEE-3941 (if not installed)
  • install SUPEE-8788 v2
  • 2
    Addition: if you managed to install v1 on 1.9.2 and solved the conflicts yourself, you don't need v2 – Fabian Schmengler Oct 17 '16 at 8:36
  • @fschmengler the v1 does not address the Unsupported data type N error so if you haven't created the lib files manually you still need to apply v2 – Raphael at Digital Pianism Oct 17 '16 at 11:45
  • 1
    Wasn't that only a problem with versions up to 1.9.1? I need to double check but don't think we had problems with our 1.9.2 installations – Fabian Schmengler Oct 17 '16 at 11:46
  • @fschmengler sorry misread 1.9.0.2 instead of 1.9.2 – Raphael at Digital Pianism Oct 17 '16 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.