1

I just upgraded from 1.9.2.4 to 1.9.3 and having a problem with the Bundle "Price as configured" price. The problem is it always shows zero no matter which bundle sub-products are selected. It was completely fine in 1.9.2.4 and only started happening in 1.9.3. By the way, this only happens to the price at the bottom near the "add to cart" button. The price at the top (right after the product title) updates as expected. This is plain unmodified RWD theme. Please help.

enter image description here

  • I just installed a fresh version of 1.9.3 and it confirms that it's definitely a bug. – Dan Oct 16 '16 at 11:30
0

To fix that issue, copy app/code/core/Mage/Catalog/Helper/Product/Type/Composite.php to app/code/local/Mage/Catalog/Helper/Product/Type/Composite.php

Then edit the app/code/local version of the file and line 130 replace:

'idSuffix'            => '',

With:

'idSuffix'            => '_clone',
  • the problem with this approach is that if & when Magento updates their core file app/code/core/Mage/Catalog/Helper/Product/Type/Composite.php your system will miss it as it will be using app/code/local/Mage/Catalog/Helper/Product/Type/Composite.php . For another approach check out magento.stackexchange.com/a/141470/6549 – Holly Oct 18 '16 at 20:19
  • @Holy well this is a temporary fix while Magento working on the new version, not meant to stay on the server – Raphael at Digital Pianism Oct 18 '16 at 20:27
0

There is also a module available which fixes this issue with a class rewrite: https://github.com/rossmc/JsonPriceFix

I also have a different solution at: https://magento.stackexchange.com/a/141470/6549

But I think the module is the cleanest solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.