0

decided to go from no suffix to adding the .html suffix in due to an easier time redirecting currently existing urls. all of my products had been imported without any suffix. when I switched the categories and products to add the .html suffix in and cleared the cache etc it does not show on any of my current products but when I import new products the suffix does show up. Can anyone help me figure out how to get my preexisting products and categories to also have the .html suffix?


I found that if I hid the category from the menu and then unhid it, that the suffix appeared for that category and all the products within that category.

3
  • 1
    make rewrite on in setting.. may be from backend or .htaccess file. Commented Oct 15, 2016 at 20:24
  • 1
    Have you tried re-indexing? Commented Oct 16, 2016 at 3:12
  • I should clarify that I did run a manual reindex and the categories and products that were preexisiting do not show the .html. The new categories and products do.
    – babywit
    Commented Oct 17, 2016 at 18:01

1 Answer 1

0

It was a re index issue all along. Thanks for the advice. Ran manual re index but it was on the wrong store so that is why it didn't alter anything. My apologies.

I found that if I hide the category from the menu and then un hide it, that the suffix appeared for that category and all the products within that category.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.