5

So I have SUPEE 1533 installed on 1.7.0.2, I DO NOT have SUPEE-3941 they are for 1.8-1.9, my version is 1.7.0.2

When I originally installed SUPEE 8788 (VERSION 1 ) I had only ONE error, and thats because of SUPEE 1533:

**

patching file app/code/core/Mage/Adminhtml/controllers/DashboardController.php
Hunk #1 FAILED at 91.
1 out of 1 hunk FAILED -- saving rejects to file app/code/core/Mage/Adminhtml/controllers/DashboardController.php.rej

**

Now, magento released SUPEE 8788 (VERSION 2) I get these errors.

patching file app/code/core/Mage/Adminhtml/Block/Dashboard/Graph.php
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file app/code/core/Mage/Adminhtml/Block/Dashboard/Graph.php.rej

patching file app/code/core/Mage/Adminhtml/controllers/DashboardController.php
Hunk #1 FAILED at 91.
1 out of 1 hunk FAILED -- saving rejects to file app/code/core/Mage/Adminhtml/controllers/DashboardController.php.rej

patching file downloader/lib/Mage/HTTP/Client/Curl.php
Hunk #1 FAILED at 372.
1 out of 1 hunk FAILED -- saving rejects to file downloader/lib/Mage/HTTP/Client/Curl.php.rej

patching file skin/adminhtml/default/default/media/flex.swf
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file skin/adminhtml/default/default/media/flex.swf.rej
patching file skin/adminhtml/default/default/media/uploader.swf
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file skin/adminhtml/default/default/media/uploader.swf.rej
patching file skin/adminhtml/default/default/media/uploaderSingle.swf
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file skin/adminhtml/default/default/media/uploaderSingle.swf.rej

I can try reinstalling Version 1 and I will get same error hunk 91. If I uninstall SUPEE 1533 I can install (8788 VERSION 1) the patch, but I will be missing 1533 patch. But installing SUPEE 8788 (version 2) and keeping 1533 patch cannot happen. I can't even install Version 2 when I reverse SUPEE 1533. New Curl.php error (hunk 372) showing, Which was not present on Version 1. Looks like it can be fixed with SUPEE 3941, but its not available for 1.7.0.2

I feel Version 2 is not much better than Version 1, even more errors. Please share your through, what shall I/We do next.

  • you have to read installation instructions... – MagenX Oct 15 '16 at 13:49
  • 2
    @MagenX They don't have SUPEE 3941 for 1.7.0.2. – Icon Oct 15 '16 at 13:50
  • magento.stackexchange.com/questions/141259/… - check out my answer. It has instructions also. I just applied SUPEE-3941 and it fixed most of the issues. – Kalvin Klien Oct 17 '16 at 21:14
1

I was able to apply 3941 successfully to 1.7.0.2 which then allowed 8788 to be applied.

Also zip the patch file before uploading it to fix the swf errors at the end

  • I applied 3941 too, but it's not meant for 1.7.0.2 I hope it doesn't break anything... Also, did you reversed Supee 1533 before applying 8788 version2. ? – Icon Oct 15 '16 at 3:09
0

Please note the right procedure to apply v2 :

enter image description here

  • 2
    The procedure states "if you have installed v1 of the patch, you have to do the following". Version 1 never installed, so I simply tried patching with V2 without the steps. – Icon Oct 15 '16 at 13:47
  • 1
    If I still should follow the steps, the issue is that they are asking to UNINSTAL 1533 and INSTALL 3941 (they dont have the 1.7.0.2 version of the SUPEE 1941)... What to do? Please advice. – Icon Oct 15 '16 at 13:48
  • @Icon afaik I don't think 1.7 needs 3941 only 1.8 and later but not 100% sure – Raphael at Digital Pianism Oct 15 '16 at 14:21
  • Well without the 1941 it throws curl.php 372 error. If I install SUPEE 1941 I can installt the patch... in fact I installed on 1.7.0.2 by compressing .zip file. removing supee 1533 and Instaling SUPEE 1941 (1.8-1.9) version... No Curl Errors.... Please make a note on official stackoverflow MAGENTO page that we cannot patch 8788 Version 2 without 1941 patch. – Icon Oct 15 '16 at 15:10
  • Have you got any information on how 1.7 users should proceed? – Icon Oct 16 '16 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.