7

After installing Patch 8788 on 1.9.2.4, product image upload says the upload is complete but it not show on the front end. I checked the media directory but image not uploaded.

  • Browser Cache will be the number one issue here. – hayres Nov 26 '16 at 10:16
2

I had this same problem, on same version of Magento CE 1.9.2.4. I was able to fix it by flushing my Magento cache (everything), then refreshing the cache (everything), then flush our CDN cache (cloudflare), then clear all browsing data from browser including cookies.

Please note that until I remembered to flush our CDN cache, our local Magento cache refresh didn't fix the problem.

Once everything was flushed and refreshed, the image uploader worked just fine.

I got the idea for this fix over on the magento community forums: https://community.magento.com/t5/Security-Patches/SUPEE-8788-Can-t-upload-images-in-product-after-patch-has-been/m-p/50463#U50463

(see onlinestore23's post half way down 1st page)

Good luck!

3

I was able to fix it,Please Follow following instruction.

Step >> 1: After installed security patch 8788 successfully, Please go to admin panel and flush all Magento cache. Then Logout your Admin Panel and Relogin to Admin Panel.

Step >> 2: Go to Index Management and select all reindex all data after flush all Magento cache once again.

Step >> 3: This very Important step, Delete your browser cache(Ctrl+shift+Delete) history clear all browsing data from browser including cookies.

Step >> 4: Go to Catalog >> Product Management , add new image of any product,now you can see everything work fine.

1

After installing Patch 8788 on 1.9.2.0 the product image upload feature appeared broken. The Browse Files/Upload Files buttons shifted to the left of the screen and were unresponsive. Refreshing the cache fixed this.

1

I have noticed this on a few site that we have done. There does not seem to be a resolution offered by Magento, as the main cause is due to the removal of the SWF files.

I have tried clearing the cache and reindexing but its not solved the issue. I have asked on the Magento forum if there is a release coming to fix this issue.

1

I was getting errors as browse files button was unresponsive. The errors in apache log were as follows

Caught race condition abuser. attacker: 1002, victim: 0 open file owner: 0, open file: /home/..../public_html/js/lib/uploader/fusty-flow-factory.js,

Well I was able to fix my issues as they relates to the Symlink Race Protection patch. It prevents cross account links from working. This means something in this area of magento is making calls to a root owned file. Particularly these files:

 /public_html/js/mage/adminhtml/uploader/instance.js

 /public_html/js/lib/uploader/flow.min.js

 /public_html/js/lib/uploader/fusty-flow-factory.js

 /public_html/js/lib/uploader/fusty-flow.js

Once I fixed the ownership of these files every thing got back to normal.

0

If you have CreareSEO installed, I fixed mine by

https://github.com/adampmoss/CreareSEO/pull/78

0

I had the same issue in magento 1.9.2.3, upload button was also shifted in the left, but the issue has been fixed after clear the cache, flush the cache then logout from admin.Now login into the admin, and the product image is uploading fine. And uploading button issue also fixed. If the issue not resolve then clear browser cache or use private window.

Not the answer you're looking for? Browse other questions tagged or ask your own question.