I want to apply the new SUPEE-8788 patch.

But when bash the patch trough SSH, I get the following error:

Checking if patch can be applied/reverted successfully...
/bin/patch: **** malformed patch at line 5790: ?rM]M??????&X㔮??v??Q;r?N?qJ??Y???I0?Y??4??'?????9?.??X?Ǒ?{??ax!G???I???q?u|????թ??????|
                                                       h??o?V@??|? ?g?H aꪭ??Ю???,I"?ğ????.??    yI?I\????)?X?
ERROR: Patch can't be applied/reverted successfully.

How can I solve this?

  • I'm getting this issue as well. If you find the solution can you please post it here
    – MakkyNZ
    Commented Oct 13, 2016 at 10:05
  • @MakkyNZ See my answer, found the problem!
    – JGeer
    Commented Oct 13, 2016 at 11:00

2 Answers 2


Found the problem!

You need to zip the file first, upload the zip trough FTP and than unzip it using SSH and bash the patch.

The patch was installed without any problem.


Did you download the official patch from Magento directly? Have you tried downloading the patch again? How did you get the patch onto your server, could that have corrupted the file on transfer?

I've run this on my systems and its worked fine every time.

From another post: Upload the file in text mode as it contains binary content

  • Thanks for your reply! Yes I downloaded it directly from the Magento website and uploaded the file trough FTP. I tried it again by downloading it again, but I still get the same error. Is it possible to get the file by using wget from the Magento server?
    – JGeer
    Commented Oct 13, 2016 at 10:49
  • Don't think so since they introduced the login barrier. Are you uploading the file in TEXT format? Which FTP program are you using? Commented Oct 13, 2016 at 11:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.