This question already has an answer here:

When applying SUPEE-8788 on Magento on OSX I get the following

sed: RE error: illegal byte sequence
Checking if patch can be applied/reverted successfully...
Patch was applied/reverted successfully.

Should I worry about the illegal byte sequence because it states it was applied successfully

marked as duplicate by Rakesh Jesadiya, 7ochem, Qaisar Satti, Amit Bera, Marius magento-1.9 Oct 21 '16 at 6:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Try running it like

LANG=C LC_CTYPE=C LC_ALL=C ./PATCH_SUPEE-8788_EE_1.13.0.1_v1.sh

This should force everything to work a bit nicer.

On OSX by default $LANG is defined like:

echo $LANG

Try running this in the command line before running the patch

export LANG=C

It should fix it, you may need to run these as well, I tried all 3 and it worked after the one above

export LL_CTYPE=C

export LL_ALL=C

Taken from this thread https://stackoverflow.com/questions/11287564/getting-sed-error-illegal-byte-sequence-in-bash

  • Does it have any negative effect on the application of the patch though? It still seems to work.. – Erfan Oct 14 '16 at 3:42

The above suggested fixes didn't work for me so I installed GNU sed from homebrew via brew install gnu-sed and changed the line in patch file to read

SED_BIN=which gsed

Not the answer you're looking for? Browse other questions tagged or ask your own question.