5

I am Trying to install sample data on xampp server using below command php bin/magento sampledata:deploy And i am getting error like this

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 40 bytes) in C:\xampp\htdocs\magento v2.0\vendor\composer\composer\src\Composer\ Json\Json File.php on line 259

can any one help me?

7

There are 2 solution for that:

Option 1 - Permanent Solution

change php.ini to increase memory_limit value on global level

memory_limit = 768M

Or You can also change in .htaccess file.

php_value memory_limit 768M
php_value max_execution_time 18000

Option 2 - Temporary Solution

quick solution add memory size in the command :

php -dmemory_limit=768M php bin/magento sampledata:deploy

change 768M to what you want

0

$ php --ini

Loaded Configuration File: /Applications/MAMP/bin/php/php7.1.8/conf/php.ini

$ nano /Applications/MAMP/bin/php/php7.1.8/conf/php.ini

change the memory_limit there and that's it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.