3

I am getting below error while changing the Default Home page from configuration on Magento Admin.

Invalid domain name: The input does not match the expected structure for a DNS hostname; The input does not appear to be a valid URI hostname; The input does not appear to be a valid local network name

enter image description here

  • Have you tried to delete all your cookies? Which option do you want to change exactly? – David Lambauer Oct 11 '16 at 7:33
0

Please follow the below-mentioned steps to set your default home page using Magento admin :

  1. On the Admin panel, click Stores. In the Settings section, select Configuration.
  2. Select Web under General in the panel on the left.
  3. Open the Default Pages section, and continue with the following:
  4. In the Default Web URL field, the default value cms or enter other value as needed.
  5. In the CMS Home Page field, select the page you want to set as home page, as normal you should select “Home Page”
  6. click Save Config.

I assure it will resolve your query.

  • Do you happen to know the path to look for in the database for the Default Web URL setting? – robgt Oct 24 '17 at 15:52
0

@Abhinav Singh...your instructions do not work. My Default Web URL is cms and I have no idea what "other value as needed" means from your instruction. The default page is always CMS. And in the CMS Home Page dropdown, it lists all the pages but it doesn't matter which one I choose from the dropdown, it does not take affect. It only show a the header and footer of my theme and the content section is blank with only "There was no Home CMS page configured or found. " written out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.