1

Magento 2.1 site, with varnish cache configured.

But whenever I make changes (e.g. changed "payment methods") at configuration of admin end, the changes are not effective on the front end. I can see the settings have been changed at the admin backend.

I also cleared all the caches, flushed magento caches; index management is set to "update on save".

So what am I missing here? Thanks for your advice!

3
  • 1
    make sure you don't have other settings saved for the same fields in the website or store view level. If you are changing the global values and there are other values at website or store view level they will not get overwritten.
    – Marius
    Oct 7, 2016 at 6:47
  • You are right, @Marius! Thanks for the tips! I saved all settings under "default config" before I enabled Varnish cache, which was fine. But after enabling Varnish cache, I found saving settings to default config is no longer effective, with your hints, I saved under "main website", now it works. Although I don't quite understand why it worked before, but not now Oct 7, 2016 at 7:20
  • Please write what you did exactly, as an answer and mark it as accepted. Maybe it will serve future readers.
    – Marius
    Oct 7, 2016 at 7:24

1 Answer 1

1

With the hints from @Marius, I found the issue is with "store view".

Before Varnish cache is enabled, I saved all settings under "default config", which worked fine. But after Varnish cache is used and enabled, I found saving settings under "default" config is no longer effective.

I switched to "Main Website", and saved the settings again, everything is working.

Although, I didn't quite quite understand why it worked before, but not now.

Hopefully it is helpful to you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.