1

I developed a site in magento on windows 7, and now my system has been updated and install an ubuntu 12.04 in it.

Now when I am running my site in browser I got an issue that my css is not loaded from the path which is loaded before.

Firstly my css path is like this

http://127.0.0.1/magento/skin/frontend/default/sportation/css/style.css

sportation is my custom theme, and now in ubuntu path is like this

http://127.0.0.1/magento/skin/frontend/base/default/css/style.css

Can anyone tell me why it is loading a css from the base theme I didn't understand, not only style.css every css is getting the path of the base theme.

My custom theme is still in working but not the css. How can I set the correct path.

Thanks.

  • Make sure the rights and site owner are correct. the rights should be 664 and the owner should match your FTP username – Sander Mangel Feb 27 '14 at 7:57
  • I had already given full rights permission to my site, but not happening, and my site is on xampp server. – Waseem Feb 27 '14 at 8:12
  • check the filenames, if it is on Windows developed, there might be uppercase/lowercase issues – Fabian Blechschmidt May 28 '14 at 14:39
  • @FabianBlechschmidt I have checked all the files, all are in lowercase. I really have no idea why it is not taking the path. – Waseem May 28 '14 at 14:47
  • The magento default filename is styleS.css Maybe this is the problem? – Fabian Blechschmidt May 28 '14 at 14:57
2

First clear the cache. It won't do you any good but do it anyway.
Then make sure that your theme is set to sportation under System->Configuration->Design->Themes->Skin (Images / CSS).
Then make sure you don't have a custom theme set in System->Design.
Make sure the style.css from sportation exists and is readable.
Make sure your theme name does not contain uppercase letters. So Sportation works on Windows but it doesn't work on linux.

  • Thanks Marius I tried it, but doesn't do anything, still getting the base path. I also clear the var/cache/folder but no luck – Waseem Jan 28 '14 at 7:52
  • I also tried the solution provide here except the first answer because I dont have .htaccess file in my root. – Waseem Jan 28 '14 at 8:00
0

Sounds like you have merge CSS enabled

  • Remove media/css and media/js directories (Same for the secure js_secure and css_secure

Make sure Media dir is writeable

Alternatively, turn off merge CSS System > Merge CSS

It will revert to this basename if it is unable to access the files.

So check your permissions of directories and check your xml files. If it's just the CSS that's not loading then you may wish to check to see that it's spelt style.css in the xml

0

You must need to check the PACKAGE which you are using that package info you will get form admin panel system->configuration

select your store and go to WEB tab then check which package and theme you are using now. first change from that then clear CACHE and then try to refresh your page . It will appear to the front end side :)

0

Change Permission Of Skin And Media Containing All Folder TO Give Permission 755 And File TO 644

Like enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.