1

we have recently installed Redis Cache for our magento based sites.

we 2 websites on our server both using same redis server, our server is based on linux with centos.

the issue we are facing is that redis is consuming quite a lot of RAM, and it is growing by every day.

we have set some values on our magento local.xml file for redis

    <redis_session>    
    <host>xxxxxxx</host>                          
    <port>xxxx</port>
    <password></password>                            
    <timeout>2.5</timeout>                             
    <persistent></persistent>                            
    <db>1</db>                                          
    <compression_threshold>2048</compression_threshold>  
    <compression_lib>gzip</compression_lib>            
    <log_level>1</log_level>                           
    <max_concurrency>6</max_concurrency>               
    <break_after_frontend>5</break_after_frontend>     
    <break_after_adminhtml>30</break_after_adminhtml>
    <first_lifetime>86400</first_lifetime>               
    <bot_first_lifetime>60</bot_first_lifetime>
    <bot_lifetime>7200</bot_lifetime>           
    <disable_locking>0</disable_locking>        
    <min_lifetime>60</min_lifetime>             
    <max_lifetime>2592000</max_lifetime>
   <automatic_cleaning_factor>1</automatic_cleaning_factor>        
</redis_session>

it seems like we do not have an expire set to it, plus there is no memory usage limit either.

i know there are few instruction on internet for setting expire but there is nothing for use with magento in easy way.

all help is apreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.