0

For a product, I added all the fields, and the product doesn't show anywhere on front end Magento. These are the things I did:

-I added the product in admin
-Added fields:
-General -> Sku, Weight, Status(Enabled), Visibility(Catalog, Search)
-Prices -> Price, Tax Class
-Added images
-Inventory -> quantity is set
-Inventory -> Stock Availability = In Stock

  • try with site-url/product-url.html – Baby in Magento Oct 3 '16 at 9:11
  • I tried and I'm getting 404 error. – Vladimir Despotovic Oct 3 '16 at 9:12
  • 1
    have you assigned website to the product – Arun Karnawat Oct 3 '16 at 9:13
  • No, but where can I do that? – Vladimir Despotovic Oct 3 '16 at 9:14
  • @VladimirDespotovic can you see website menu on left side at the time of editing product ? you can click on there and select checkbox & save it..... – Baby in Magento Oct 3 '16 at 9:25
0

Edit you product and select website tab on left and select the website. see image below

enter image description here

enter image description here

  • Somehow I don't have "Websites" in the admin menu. Only these: General, Prices, Meta Information , Images, Recurring Profile, Design, Gift Options, Inventory, Categories, Related Products, Up-sells, Cross-sells, Product Reviews, Product Tags, Customers Tagged Product, Custom Options. – Vladimir Despotovic Oct 3 '16 at 9:43
  • in that case, check the followings: Status :Enable, Visibility :Catalog, Search, Stock Availability:In Stock – Arun Karnawat Oct 3 '16 at 9:51
  • Everything is set correctly (Status=Enabled, Visibility=Catalog, Search, Stock Availability=In Stock). – Vladimir Despotovic Oct 3 '16 at 10:01
  • the only thing I can think of now is, try reindexing, then clear cache. – Arun Karnawat Oct 3 '16 at 10:06
  • It doesn't work. Thanks though. – Vladimir Despotovic Oct 3 '16 at 13:02
0

At the end, it seems that issue was at category level. The category wasn't set to display products. I resolved it by setting this for the category: Display settings -> Display mode -> Static block and products instead of Display settings -> Display mode -> Static block only

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.