1

I just installed SMTP Pro extension for sending emails by SMTP. I get the following errors:

Detected overwrite conflict:

CRM4Ecommerce_CRMCore_Model_Rewrite_Core_Email_Template

Please help and consider that I'm new to magento. I couldn't find a solution in the internet. I run Magento 1.9.2

  • CRM4Ecommerce_CRMCore is this module belongs to smtp pro? – saravanavelu Sep 29 '16 at 4:28
  • @saravanavelu No. This is another module that I installed – ASH Nov 27 '17 at 5:12
0

You can solve this conflict by following go to this class file app/code/CLASSCODEPOOL/CRM4Ecommerce/CRMCore/Model/Rewrite/Core/Email/Template.php and change its extending class to

Aschroder_SMTPPro_Model_Email

so your class would be like this

class CRM4Ecommerce_CRMCore_Model_Rewrite_Core_Email_Template extends Aschroder_SMTPPro_Model_Email{
    //your methods  .....
} 
| improve this answer | |
  • I did as you explained but now I get other messages!! SMTP Pro Self Test Results Detected overwrite conflict: CRM4Ecommerce_CRMCore_Model_Rewrite_Core_Email_Template Test email was sent successfully. Could not test default template validity. Exception message was: Invalid method CRM4Ecommerce_CRMCore_Model_Rewrite_Core_Email_Template::loadDefault(Array ( [0] => contacts_email_email_template [1] => en_US ) )... Please check that you have templates in place for your emails. These are in app/locale, or custom defined in System > Transaction Emails. – ASH Sep 30 '16 at 2:40
  • so your solution is to replace (Mage_Core_Model_Email_Template) with (Aschroder_SMTPPro_Model_Email) which I did but now I get the error message above. – ASH Sep 30 '16 at 2:42
  • you have to change your config.xml as well now you need to rewrite the SMTPpro extension model instead core email model – Murtuza Zabuawala Sep 30 '16 at 2:59
  • I don't think that I understood what you just said. Can you please explain? I'm new to this. – ASH Sep 30 '16 at 3:08
  • I just noticed when I edited the file you mentioned above and extended the class to Aschroder_SMTPPro_Model_Email all transactional emails stopped working even if I try to preview a transactional email template. I restored the files and everything went back to normal. Still can't figure out how to fix this issue. Both authors and their websites don't respond so far. – ASH Sep 30 '16 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.