2

When i try to open my site it is not opening, same as my back end as i added the error below.

Adminpanel issue in site.

enter image description here

1

It looks like your magento is unable to read the xml configuration files. Try giving appropriate read permission to all your xml files and try.

cd your/magento_root/
find . -type f -name '*.xml' -exec chmod 644 {} \; 
  • How can i give read permission to my xml file – Gem Sep 27 '16 at 5:40
  • Revised my answer, check it – Nidheesh Sep 27 '16 at 9:59
  • i.imgur.com/gfnDd3I.png – Gem Sep 27 '16 at 10:06
  • not working.... – Gem Sep 27 '16 at 10:06
1

The problem is the magento can't read your xml files. Check the file permission, remove the cache. Make sure your file permissions are set to

Directories : 755 ::: Files : 644

  • how can i check permission and how can i change permission – Gem Sep 27 '16 at 5:39
  • Are you using ubuntu or windows ? – Krishna ijjada Sep 27 '16 at 5:42
  • windows only... – Gem Sep 27 '16 at 5:52
  • magento version 1.9.2.3, – Gem Sep 27 '16 at 5:54
  • google.co.in/… – Krishna ijjada Sep 27 '16 at 5:55
1

Reason 1

Try clearing cache, and check file permissions are correctly set,

Directories : 755

Files : 644

Else another alternative is Reinstall Magento and do following steps:

It may solve the issue, but suggested to have round of research before doing and surely back up database:

Before to import database : - Add query

1) SET SQL_MODE=”NO_AUTO_VALUE_ON_ZERO”; 

OR

at beginning of sql import script

After import / installation : - Execute following query

2) UPDATE `core_store` SET `store_id` = 0 WHERE `code` like 'admin';
   UPDATE `core_website` SET `website_id` = 0 WHERE `code` like 'admin';
   UPDATE `customer_group` SET `customer_group_id` = 0 WHERE `customer_group_code` like 'NOT LOGGED IN';

Reason 2

The problem is the magento can't read your xml files. So check file permission again for xml files and check your xml files under app/etc folder and every custom modules under app/code/local/ may be some xml files are corrupted (miss formed).

clear cache

Note:- not given proper permission also occurs this error.

0

open your terminal or connect your website via ssh access and fire below command one by one for file/directory permission

chmod -R 644 ./*
find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;
chmod 550 ./mage
  • could you pls briefly explain, i run in my local host – Gem Sep 27 '16 at 7:06
  • your problem is related is file permission so open your terminal and fire above command one by one – Murtuza Zabuawala Sep 27 '16 at 7:11
  • i.imgur.com/m6NSZhV.png – Gem Sep 27 '16 at 7:16
  • how can i run these commands – Gem Sep 27 '16 at 7:16
0

The problem is the Magento can't read your XML files. So check file permission again for xml files and check your xml files under app/etc folder and every custom modules under app/code/local/ may be some XML files are corrupted (miss formed).

just run an rsync -p on with your production site

Can Use cleanup Script for your localhost cleanup script

Not the answer you're looking for? Browse other questions tagged or ask your own question.