1

This is intended canonical question

When we are trying to upgrade our Magento store from 2.0.x to 2.1.x (2.0.7 to 2.1.1).

What changes we have to do in Admin panel OR what things we have to consider after upgrade so that our theme and custom module will work properly also which PHP ver required for this ?

0

In your admin panel you don't have to change anything.

Your custom modules, however, will need extensive testing. Since you don't provide any info about these modules, it is impossible to say whether they will work or not.

As a hint: upgrading can take a lot of time. keep calm even when the log stops for a longer period of time.

0

Please follow the same order and use the commands listed below:

composer require magento/product-community-edition 2.1.0 –no-update

Note: As 2.1.0 is the latest version, these numbers can be changed accordingly.

composer update

Note: It will ask for repo.magento.com authentication keys. For more information, visit this link.

rm -rf var/di var/generation

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento cache:clean

php bin/magento cache:flush

php bin/magento indexer:reindex

0

If you are still working only on a development enviorenment (without push it on production env), I recommend you install a fresh magento 2.1.x and move your modules into it. I was working on magento 2.0.7 and updated to 2.1.0. It was a big headache due to issues on singlestore mode and core upgrade scripts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.