2

enter image description here

enter image description here

Has anyone experienced this issue? There is only one category that will show up in the menu and there are no subcategories that will show up.

I've tried:

  • *both developer mode and production
  • *cleared cache
  • *reindexed
  • *rebooted
  • *checked permissions
  • *using flat categories
  • *different browsers
  • *verified max depth
  • *verified all categories are anchors

Thank you in advance.

3
  • Check all categories is anchor is or not in admin ? Sep 22, 2016 at 17:27
  • All the categories both root and sub are all set as Anchor = yes and I've verified that all of the settings are exactly the same between all of them as well. Note, the categories are added via API.
    – Jessica
    Sep 22, 2016 at 17:43
  • It looks like anything I add manually will appear however, if the category is added via REST API then it won't show up in the GUI.
    – Jessica
    Sep 22, 2016 at 18:49

1 Answer 1

1

CategoryHierarchy

Visually on the admin GUI the sub is put into the correct location but, the position and level and are not updated in the return result string so it doesn't show up correctly on the customer's UI.

You will need to, in your code, anticipate the correct position and level of the category in the category hierarchy when adding it via API.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.