0

I'm trying to install Magento 2.1.1 on unix server but when it does system check I keep on getting following error message and application will not install.

Your PHP Version is 5.6.22, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

After using:

phpinfo();

I get:

Configuration File (php.ini) Path /opt/alt/php56/etc

Loaded Configuration File /home/some9753/public_html/php.ini

Scan this dir for additional .ini files /opt/alt/php56/link/conf

Additional .ini files parsed /opt/alt/php56/link/conf/alt_php.ini

I don't have access to the directories /opt/alt/php56/etc, apart from that in the php info file always_populate_raw_post_data is set to -1 for Local Value as well as Master Value.

The Loaded Configuration File php.ini was created by myself and and placed in public_html folder. It contains:

always_populate_raw_post_data = -1;

But it is not solving problem. I don't know how the installer is coming up with always_populate_raw_post_data = 0 when it is not set to that value anywhere. Any suggestion as to what I should do to solve problem? All help will be greatly appreciated.

  • So do you check the info showing when using phpinfo(); is that always_populate_raw_post_data = -1 ? – David Nguyen Sep 22 '16 at 4:49
  • Ye, it is always_populate_raw_post_data = -1 – raydona Sep 22 '16 at 14:34
1

If you are changing always_populate_raw_post_data you will need to restart the server for it to take effect.

0

When faced this problem I did the following steps do as described

  1. Set the php version of the system to the latest one.
  2. Open php.ini file & enable the php_intl.dll by removing the coma before the name.
  3. Restarted the sever.

It starts working!

-1

You can edit a file in Ubuntu not having direct permission using command line editor sudo nano /etc/php/5.6/apache2/php.ini

It will open a editor and you can fetch always_populate_raw_post_data = 0; and change it to always_populate_raw_post_data = -1;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.