0

I know this question gets asked A LOT on this forum, but I just cannot get the url to change. I'm working on a test-site to try out a new theme (fortis), and no matter what I do it tries to retrieve the styling files from the old website URL instead of the new one.

What I've tried so far:

  • Change base URL
  • Change secure / unsecure URL
  • Gone through and edited all basic xml files (like local.xml) and replaced the old url with the new one
  • Went through the database to check for old links
  • Spent hours and hours just trying to fix this one thing!

The theme works, it's just this one single problem that it tries to retrieve the styling files from the old url. The path is correct, it's just the base url that is wrong... It really drives me insane that I've changed the base url and for some reason it still tries to get them from the old website... Like... What???

Does anyone have any hints? I'm getting kind of desperate here if you haven't noticed already haha.

Thanks

EDIT: I do not have any caching enabled, and make sure to clear the cache manually anyway just to make sure, but to no avail...

  • did you clear your cache? – Qaisar Satti Sep 21 '16 at 9:25
  • @QaisarSatti Yes I forgot to mention that. I don't have any kind of caching enabled and yet I even have tried clearing the cache several times anyway without any luck. I'll edit the question – trossn Sep 21 '16 at 9:27
  • @trossn Check whether you have magento cache in /tmp directory of your server, if yes clear that and give write permission to your magento var/cache directory. – Nidheesh Sep 21 '16 at 9:28
  • @Nidheesh My tmp folder is empty and the cache folder has got every permission there is. Still no luck i'm afraid. – trossn Sep 21 '16 at 9:30
  • 1
    @Nidheesh I think I solved it. I'll answer the question, hold on... – trossn Sep 21 '16 at 9:46
1

I think I fixed it. I used this SQL query to see all the links in the database:

Select * from core_config_data where value like 'http%';

This shows all the links. Apparently there is a lot of different web/secure and skin urls in the database. I had only changed a few... But now it's fixed!

I hope this query helps someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.