1

I have carefully follow instruction to setup SSL in Front-end and Admin panel by using

System -> Configuration -> Web -> Use Secure URLs in Frontend

and

System -> Configuration -> Web -> Use Secure URLs in Frontend

to "Yes"

After that I can't access my Administrator Panel anymore, it always redirected to https.

I have tried to revert the config. But still no luck, I also have change database table : core_config_data. web/secure/use_in_frontend and web/secure/use_in_adminhtml to 0 and web/secure/offloader_header is SSL_OFFLOADED.

Also, remove cache and session data. Still no luck.

I using Magento 1.9 and Nginx.

I got it, it was the Magento cache problem, somehow it was cache inside the folder /tmp/magento/var/cache of my Linux (not Magento tmp folder). After I delete it, I can finally access my adminhtml using HTTP.

0

I can tell you one solution I dont know you have tried or not But you can try below solution

go to your mysql

fire this query SELECT * FROM mgnt_core_config_data WHERE path='web/unsecure/base_url'

and change your unsecure base url to your url without https, so it would be http://your_base_url

Try And let me know if it works

  • Thank you for you reply, I have tried to change the url to http, but still no luck – William Sep 21 '16 at 7:06
  • You using any cdn ? if yes then try to purge that cdn – Murtuza Zabuawala Sep 21 '16 at 7:07
  • I currently didnt use any cdn. By the way, this problem also occurred in Front-end pages which has any textbox or input such as Login and Signup page. – William Sep 21 '16 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.