0

I have a similar problem. My compiler was turned on and I did the installation. Now, getting error 500 and log file shows this error

[21-Sep-2016 01:25:37 UTC] PHP Fatal error: Class 'Aschroder_SMTPPro_Model_Mysql4_Setup' not found in /home/strateg2/public_html/picworks.in/includes/src/Mage_Core_Model_Resource_Setup.php on line 234

I'm unable to log in to admin panel. How to resolve this issue.

2

Solution 1:

Turn Off the compiler from your terminal steps

1) open your terminal /connect your ssh access

2) go to your magento root via this command cd \yourpathtomagentoDir

3) fire this commnad php -f compiler.php disable

4) after this do compile php -f compiler.php compile

5) after this enable compile php -f compiler.php enable

Solution 2:

1) go to your module's xml file located in app/etc/modules and disable the module

2) clear the cache

3) now you are able to login in back end

4) disable the compiler and install your module

5) do compile and enable your magento compile

0

I think Aschroder SMTPPro extension does not posses it's set up file. So create a file like this.

File: app/code/<codePool>/Aschroder/SMTPPro/Model/Mysql4/Setup.php

<?php
class Aschroder_SMTPPro_Model_Mysql4_Setup extends Mage_Sales_Model_Mysql4_Setup
{
}

That will resolve this issue.

Note: codepool may be local or community depends upon where Aschroder_SMTPPro module resides.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.