0

Running Magento 1.9.2.4 in GoDaddy.

I'm trying to import about 1000+ simple products. The weird thing is that I can't import anything past the 40th-ish product. which is really weird since I had already done another import previously (of about 300 products) with no problem.

I keep getting this error when trying to import through the normal import:

Product Type is invalid or not supported in rows: 44, 45, 46, 47, 48, 49, 50, 51...

And so on and forth until reaching the 100th error limit, invalidating my file.

(This error stems from the csv containing all products).

I've tried splitting it, but to no avail, it is always after a certain product that I just can't add them, no matter how many times I create a new csv or which configurations I use (I'm sure I've done everything correctly, from encoding in UTF-8, even deactivate BOM and all. I'm using OpenOffice and Notepad++ to edit my files too) which I find weird because the first 40 products don't cause any issue.

Dataflow doesn't help either. It seems to start working correctly, but after a while I start getting some blank errors, and ultimately nothing is added to the database.

Any help?

To clarify, of my 1000-ish products, I've already imported the first 40, but Magento just won't import the rest. I also made another csv containing just the products that are left, Magento tells me that the product type isn't valid, when they all have the same thing (simple) in the column type of the "working" products.

  • What is the product type in this lines? Are you sure, there is no space before or after? Check the CSV in a file editor! – Fabian Blechschmidt Sep 20 '16 at 21:28
  • 1
    It is definitely your data, I'd say you would have to share a couple rows, preferably ones that are likely to be the culprit, in order for anyone to point you to the issue – Goku Sep 21 '16 at 5:13
  • I'm simply writing "simple" in my product type column. I've even copy-pasted the cell from the working products, to no avail. – lower Sep 21 '16 at 15:14
  • Didn't realize hitting enter would post the comment. Oops Also, I've quadruple-checked my files, through Notepad++, Notepad, Excel and OpenOffice Calc, and at least according to Notepad++, all the files seem to be the same. There are no spaces before or after the type column, and I'm certain I've been encoding correctly. – lower Sep 21 '16 at 15:18
  • Did some more testing... the results are weird, to say the least. I took one of the "working" products and started messing with it, validating each change each time with the importer. From my tests, any little change to the sku will invalidate the product completely, though the importer tells me the problem is in the type field; on the other hand, entering any junk in the type field doesn't affect it (provided I didn't change the sku), resulting in a simple product. At this point I believe this is a problem with the importer rather than my files. – lower Sep 21 '16 at 16:46
0

Without getting your csv I do not think you can find the answer here. Though I can suggest it is a data problem because of the following line:

I've tried splitting it, but to no avail, it is always after a certain product that I just can't add them

I would recommend removing this 1 product from the csv and seeing if the rest of the file is valid and does not cause any issues. Unfortunately there is probably no alternative then to go line by line and look for the formatting error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.