0

I set up my site on my test server and after moving it to my live domain, its giving me

Autoload error

Vendor autoload is not found. Please run 'composer install' under application root directory.

Please suggest me how to fix this issue.

Thanks

1
  • is your issue solved? – zus Oct 26 '17 at 6:30
3

I fixed the issue by running command

  composer install

in magento directory.

1
0

Before run "composer install" show me this below

Problem 1 - Installation request for magento/product-community-edition 2.1.6 -> satisfiable by magento/product-community-edition[2.1.6]. - magento/product-community-edition 2.1.6 requires ext-gd * -> the requested PHP extension gd is missing from your system. Problem 2 - Installation request for phpunit/phpunit 4.1.0 -> satisfiable by phpunit/phpunit[4.1.0]. - phpunit/phpunit 4.1.0 requires ext-dom * -> the requested PHP extension dom is missing from your system. Problem 3 - theseer/fdomdocument 1.6.6 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.6.5 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.6.4 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.6.3 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.6.2 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.6.1 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.6.0 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.5.0 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.4.3 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.4.2 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.4.1 requires ext-dom * -> the requested PHP extension dom is missing from your system. - theseer/fdomdocument 1.4.0 requires ext-dom * -> the requested PHP extension dom is missing from your system. - sebastian/phpcpd 2.0.0 requires theseer/fdomdocument ~1.4 -> satisfiable by theseer/fdomdocument[1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.5.0, 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6]. - Installation request for sebastian/phpcpd 2.0.0 -> satisfiable by sebastian/phpcpd[2.0.0].

To enable extensions, verify that they are enabled in your .ini files: - /etc/php/7.0/cli/php.ini - /etc/php/7.0/cli/conf.d/10-mysqlnd.ini - /etc/php/7.0/cli/conf.d/10-opcache.ini - /etc/php/7.0/cli/conf.d/10-pdo.ini - /etc/php/7.0/cli/conf.d/20-calendar.ini - /etc/php/7.0/cli/conf.d/20-ctype.ini - /etc/php/7.0/cli/conf.d/20-exif.ini - /etc/php/7.0/cli/conf.d/20-fileinfo.ini - /etc/php/7.0/cli/conf.d/20-ftp.ini - /etc/php/7.0/cli/conf.d/20-gettext.ini - /etc/php/7.0/cli/conf.d/20-iconv.ini - /etc/php/7.0/cli/conf.d/20-json.ini - /etc/php/7.0/cli/conf.d/20-mysqli.ini - /etc/php/7.0/cli/conf.d/20-pdo_mysql.ini - /etc/php/7.0/cli/conf.d/20-phar.ini - /etc/php/7.0/cli/conf.d/20-posix.ini - /etc/php/7.0/cli/conf.d/20-readline.ini - /etc/php/7.0/cli/conf.d/20-shmop.ini - /etc/php/7.0/cli/conf.d/20-sockets.ini - /etc/php/7.0/cli/conf.d/20-sysvmsg.ini - /etc/php/7.0/cli/conf.d/20-sysvsem.ini - /etc/php/7.0/cli/conf.d/20-sysvshm.ini - /etc/php/7.0/cli/conf.d/20-tokenizer.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.