2

We upgraded to paypal pro and then we start receiving IPN problems. We are receiving IPN warning emails from paypal and we continue to get problems where: paypal receives the order information but nothing is confirmed back to our Magento database. The IPN history report from my paypal shows IPN retrying and failiure. On all the retry/failiure status we have no order recorded in Magento but we do have the paypal payment. It seems that Magento says processing payment and then returns to the shopping cart and does not show the Magento completed transaction page. Therefore the information goes out but the IPN does deliver back from paypal in our Magento.

Here is what our server side have commented; We can see the following messages when the IPN requests are being served:

[22/Jan/2014:09:39:10 -0600] "POST /paypal/ipn/ HTTP/1.0" 503 - "-" "PayPal IPN ( [link removed] )" [22/Jan/2014:09:44:31 -0600] "POST /paypal/ipn/ HTTP/1.0" 503 - "-" "PayPal IPN ( [link removed] )" [22/Jan/2014:09:55:12 -0600] "POST /paypal/ipn/ HTTP/1.0" 503 - "-" "PayPal IPN ( [link removed] )" [22/Jan/2014:10:16:33 -0600] "POST /paypal/ipn/ HTTP/1.0" 503 - "-" "PayPal IPN ( [link removed] )" [22/Jan/2014:09:31:16 -0600] "POST /paypal/ipn/ HTTP/1.0" 503 - "-" "PayPal IPN ( [link removed] )"

As per the logs of the suexec log on our servers (the service that executes your PHP scripts):

Code:

[2014-01-22 10:16:28]: info: [usr/grp]: cucumber/cucumber cmd: /home/cucumber/public_html/index.php php: /usr/local/php53/bin/php
[2014-01-22 10:16:28]: info: [usr/grp]: cucumber/cucumber cmd: /home/cucumber/public_html/index.php php: /usr/local/php53/bin/php
[2014-01-22 10:16:30]: info: [usr/grp]: cucumber/cucumber cmd: /home/cucumber/public_html/index.php php: /usr/local/php53/bin/php
[2014-01-22 10:16:33]: info: [usr/grp]: cucumber/cucumber cmd: /home/cucumber/public_html/index.php php: /usr/local/php53/bin/php

I can also see that in some cases the requests are processed properly, which is quite strange:

Code:

[22/Jan/2014:08:12:05 -0600] "POST /paypal/ipn/ HTTP/1.0" 200 - "-" "PayPal IPN ( [link removed] )"

The requests have been served properly by our server, since it executes the index.php file and it seems that the 503 error message is being returned by the Magento application itself, but not by our server.

If the message was being returned by our server, the index.php script would not be executed at all.

I am stuck with the next action in resolving this, any comments would be appreciated.

  • Hi, have you tried the guide by Inchoo on debugging IPN? inchoo.net/ecommerce/magento/debugging-paypal-ipn-in-magento – ProxiBlue Jan 23 '14 at 13:00
  • Hi Marius, Would the inchoo debug code create a log in the base>var>log? – Dan Jan 23 '14 at 20:25
  • The retry/failiure only occurs when the payment detail is made on the website, if via paypal everything is OK. I have set the debug and hope to have some more information soon. – Dan Jan 23 '14 at 22:17
  • Marius did you get a fix for this? I'm having the same issue and PayPal and Server Admin both say is from a script in Magento. I just can't figure it out why a 503 is returned and when I access my paypal/ipn I get a 200 Ok status. – MMScreenX Jul 29 '14 at 6:21
2

The exception.log file kept recording SQL error server gone away. Problem solved by upgrading the server from shared to dedicated and increasing timeout settings from 10 secs top 120 secs and max packets from 8mb up to 16mb

-1

I had also a lot of problems with failed IPNs. I thought this might interest you: I use now this plugin http://www.sellxed.com/shop/en/magento-paypal-zahlungs-extension.html which works directly with the API from PayPal. I had so far no problems with it.

Cheers

  • Welcome to SE. Please don't add single link answers. Explain in a few words what the extension does. – Marius Jan 21 '15 at 11:19
  • This is an advert for a paid extension, not an answer. – Dom Feb 5 '16 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.