0

Magento Customer Login not working, getting loading by long time. I looks the log file. Show the below error please help me.

 2016-09-16T12:44:24+00:00 ERR (3): 
exception 'Exception' with message 'Minify_YUICompressor : $jarFile(/var/www/site/lib/yuicompressor/yuicompressor.jar) is not a valid link.' in /var/www/site/lib/Minify/YUICompressor.php:161
Stack trace:

#0 /var/www/site/lib/Minify/YUICompressor.php(103): Minify_YUICompressor::_prepare()
#1 /var/www/site/lib/Minify/YUICompressor.php(74): Minify_YUICompressor::_minify('js', '/*  Prototype J...', Array)
#2 /var/www/site/app/code/local/Sm/Market/Helper/Core/Data.php(53): Minify_YUICompressor::minifyJs('/*  Prototype J...')
#3 /var/www/site/app/code/local/Sm/Market/Helper/Core/Data.php(236): Sm_Market_Helper_Core_Data->minifyJsCss('/*  Prototype J...', '/var/www/sit...')
#4 /var/www/site/app/code/core/Mage/Core/Model/Design/Package.php(727): Sm_Market_Helper_Core_Data->mergeFiles(Array, '/var/www/sit...', false, NULL, 'js')
#5 /var/www/site/app/code/core/Mage/Core/Model/Design/Package.php(641): Mage_Core_Model_Design_Package->_mergeFiles(Array, '/var/www/sit...', false, NULL, 'js')
#6 [internal function]: Mage_Core_Model_Design_Package->getMergedJsUrl(Array)
#7 /var/www/site/app/code/core/Mage/Page/Block/Html/Head.php(276): call_user_func(Array, Array)
#8 /var/www/site/app/code/local/Sm/Market/Block/Page/Html/Head.php(221): Mage_Page_Block_Html_Head->_prepareStaticAndSkinElements('<script type="t...', Array, Array, Array)
#9 /var/www/site/app/design/frontend/sm_market/default/template/page/html/head.phtml(73): Sm_Market_Block_Page_Html_Head->getCssJsHtml()
#10 /var/www/site/app/code/core/Mage/Core/Block/Template.php(245): include('/var/www/sit...')
#11 /var/www/site/app/code/core/Mage/Core/Block/Template.php(276): Mage_Core_Block_Template->fetchView('frontend/sm_mar...')
#12 /var/www/site/app/code/core/Mage/Core/Block/Template.php(290): Mage_Core_Block_Template->renderView()
#13 /var/www/site/app/code/core/Mage/Core/Block/Abstract.php(919): Mage_Core_Block_Template->_toHtml()
#14 /var/www/site/app/code/core/Mage/Core/Block/Abstract.php(637): Mage_Core_Block_Abstract->toHtml()
#15 /var/www/site/app/code/core/Mage/Core/Block/Abstract.php(581): Mage_Core_Block_Abstract->_getChildHtml('head', true)
#16 /var/www/site/app/design/frontend/sm_market/default/template/page/2columns-left.phtml(38): Mage_Core_Block_Abstract->getChildHtml('head')
#17 /var/www/site/app/code/core/Mage/Core/Block/Template.php(245): include('/var/www/sit...')
#18 /var/www/site/app/code/core/Mage/Core/Block/Template.php(276): Mage_Core_Block_Template->fetchView('frontend/sm_mar...')
#19 /var/www/site/app/code/core/Mage/Core/Block/Template.php(290): Mage_Core_Block_Template->renderView()
#20 /var/www/site/app/code/core/Mage/Core/Block/Abstract.php(919): Mage_Core_Block_Template->_toHtml()
#21 /var/www/site/app/code/core/Mage/Core/Model/Layout.php(555): Mage_Core_Block_Abstract->toHtml()
#22 /var/www/site/app/code/core/Mage/Core/Controller/Varien/Action.php(390): Mage_Core_Model_Layout->getOutput()
#23 /var/www/site/app/code/core/Mage/Customer/controllers/AccountController.php(117): Mage_Core_Controller_Varien_Action->renderLayout()
#24 /var/www/site/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Customer_AccountController->indexAction()
#25 /var/www/site/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('index')
#26 /var/www/site/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#27 /var/www/site/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#28 /var/www/site/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#29 /var/www/site/nl/nl/index.php(87): Mage::run('nl_nl', 'store')
#30 {main}

Line #23 Getting related to customer login issue. please help me,, please avoid to tell add the form key option in login form. because. error not caused by the form_key.

4
  • Have you enable minify function from admin ? Sep 16, 2016 at 9:19
  • yes, i enabled.
    – Crock
    Sep 16, 2016 at 9:19
  • Try it disable and check it. Sep 16, 2016 at 9:20
  • I disabled and enabled, still customer account not login in frontend.
    – Crock
    Sep 16, 2016 at 9:23

2 Answers 2

0

For security reasons in Magento - hidden-fields with form keys were added. If you have a custom theme or if you updated core Magento only and old templates have left - your login/registration forms could stop working.

E.g. There should be ?php echo $this->getBlockHtml('formkey'); ?> for login form.

And for register you should use <input type="hidden" name="form_key" value="<?php echo Mage::getSingleton('core/session')->getFormKey() ?>" />

You can check this in Twitter and Facebook Free extension by Plumrocket, in the following files:

app/design/frontend/base/default/template/pslogin/customer/form/login.phtml

app/design/frontend/base/default/template/pslogin/customer/form/register.phtml

You can also use this module, as it is integrated with many themes.

Regards, Plumrocket Team

2
  • Actually i did all above mentioned two, still having the issue
    – Crock
    Sep 16, 2016 at 11:18
  • This is not the answer for the question. please anyone?
    – Crock
    Sep 16, 2016 at 11:24
0

The error log is telling you exactly what is wrong:

/var/www/site/lib/yuicompressor/yuicompressor.jar is not a valid link

To pinpoint the problem I would suggest disabling (by renaming the app/etc/modules/Module_Name.xml file to app/etc/modules/Module_Name.xml.disabled) or removing entirely whatever extension is attempting to Minify your output.

2
  • Module_Name (yuicompressor.xml) file is not there @BlueC
    – Crock
    Sep 16, 2016 at 16:53
  • It's hard to tell, but it may be the Sm_Market module. However, if you disable that then I imagine the whole site/theme will break. I suppose the question is, what has happened to the /var/www/site/lib/yuicompressor/yuicompressor.jar file and why can't it be found? Can you verify that file exists?
    – BlueC
    Sep 16, 2016 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.