0

I want to remove the Keep Magento Healthy from my Footer. I followed the instructions in this question but am confused as to how to lay it out in my custom theme. How to remove "Help us keep magento healthy" in Magento 2.1

I have copied what is inside the the module-theme frontend folder from vendor/magento/module-theme/view/frontend/ into my app/design/frontend/Vendor/Theme

So currently inside of my Theme folder it looks a bit like this: Magento_Theme --layout
--templates
--html
----footer.phtlm
----bugreport.phtml
--web
--layouts.xml
etc
i18n
media
web
--css
----source

To the layout.xml files I added in the suggested to code remove the bug block

from the footer.phtml file I removed:
bug tracking link

I cleared the cache and nothing changed.

Can someone tell me where I'm going wrong? Also, on the file structure in the vendor folder you have the module_files and then you have the front end files with the css files inside. Am I correct in putting the layout.xml files into the app/design/frontend/Vendor/Theme or do the module-files all go into the app/code folder?

My apologies for these really basic questions. I cannot wait I know enough that this will look like a silly question to me! Thank you for all your help.

A novice

0

You only need to reproduce the folder structure for the files you want to extend, so if you want the change the default.xml layout file, originally in module-theme/view/frontend/layout/default.xml, you want to create the following file: app/design/frontend/YourVendorName/YourThemeName/Magento_Theme/layout/default.xml.

To remove the link, you actually have to either edit html/bugreport.phtml or remove that block altogether, I don't know where html/footer.phtml is used, but it's not in the main pages.

The prefered way is to remove the block via layout files. If you search for "Help Us Keep Magento Healthy" with you IDE, you'll find that the block is defined in default.xml and is called report.bugs.

So create your default.xml file like this:

<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
    <body>

        <referenceBlock name="report.bugs" remove="true" />

    </body>
</page>

The <referenceBlock> element means "target that block" and the rest is self-descriptive.

Don't forget to enable your theme and clearing your cache to see the change.

  • Can you mark my answer as valid, then? It'll help future newcomers. :) – ax_pernot Sep 20 '16 at 8:39
  • I'm on 2.2.2 and this didn't work for me. – Chris K Jan 5 '18 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.