I'm having problems with Magento Connect again. I'm using Magento

Last year, when using Magento, I previously had the "Unknown cipher in list: TLSv1" error when using Magento Connect to install extensions.
I used this solution to solve it:

/* $this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1'); */

However, I have since upgraded to (directly from, and now I get the error message "SSL connect error" when trying to install any extensions via Magento Connect.

Does anyone have a solution to this problem?

2 Answers 2


Change this:

$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1'); To this:

in downloader/lib/Mage/HTTP/Client/Curl.php

  • 1
    This change is already in place. (I said in the original post that I have already made this change, in order to stop the "Unknown cipher in list: TLSv1" error.) Commented Sep 16, 2016 at 9:13

It's not safe to use Magento connect for installing extension , click this link for more information.

in the worst case, if you want immediate solution , Alternatively you can install the extension through FTP (like FileZilla). You can paste the extension key in this unofficial link and you can download the extension files. Let me know if you find any problems in this.

Note : As this is unofficial 3rd party site, there is no guarantee about security. but i tested many extensions, i did't faced any security problems....

  • I'm now using this technique, just to get the extensions installed - but I'd rather use the 'official' method rather than a workaround if at all possible. Commented Sep 19, 2016 at 9:46
  • @PhilStewart thats better , best thing is installing extension in demo site and check quality of code and make sure extension will not breaks anything and install in live site Commented Sep 19, 2016 at 9:47
  • The downside is that you can't see a list of all the extensions that have been installed. Unless I'm missing something? Commented Sep 19, 2016 at 10:39
  • @PhilStewart means you are telling you want to see all extensions of the site under magento connect, you can check that by system > configuration > Advanced > Disable modules output...... Commented Sep 19, 2016 at 10:41
  • Oh that's fantastic - I've never seen that before! Commented Sep 19, 2016 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.