0

I have an issue that in my magento website admin panel is not logging in with correct username and password and also not showing any error message of invalid login with incorrect credentials.

So please let me know how I resolve the issues of admin login.

Thanks

  • You have to reset admin password from database. – Suresh Chikani Sep 15 '16 at 6:08
  • try with other browser..... – Baby in Magento Sep 15 '16 at 6:13
  • Thanks for quick reply. But nothing happen when reset password. And main thing is that its not showing any error like invalid credentials or invalid username and password. I think it may cause of sessions generate error. So please suggest me how I resolve this issues. – Vikas Pandey Sep 15 '16 at 6:45
0

you can login to phpmyadmin, search for "admin_user" field & click on that and choose MD5 and give new password & save it.

step 1 : Login to Phpmyadmin & select proper database

step 2: : search for admin_user

enter image description here

step 3 : click on admin_user

enter image description here

step 4 : select MD5 from dropdown and type new password

enter image description here

step 5 : click on "Go" button

enter image description here

you can find detailed explaination here .

0

This types of problems occures when magento fails to get domain(mainly in case of localhost). During login magento tries to create cookie. You can wether cookies are forming or not from your web browser. If it is not forming then you have to make some changes in varien.php file.

Find the following file. app\code\local\Mage\Core\Model\Session\Abstract\Varien.php

and overide it in local(make required folders if not there). Then find

if (isset($cookieParams['domain'])) {
$cookieParams['domain'] = $cookie->getDomain();
}

Simply change the condition to

if (isset($cookieParams['domain']) && !in_array("127.0.0.1", self::getValidatorData())) {
$cookieParams['domain'] = $cookie->getDomain();
}

main reason of doing so is to disable domain check if running on localhost.

0

I had fixed the above issue by following these steps.

1- Go to file app/code/core/Mage/Core/Model/session/abstract/varien.php

2- Go to line number 95 and comment out the cookieParams array and define $cookieParams as an array like below

// session cookie params
/*$cookieParams = array(
    'lifetime' => $cookie->getLifetime(),
    'path'     => $cookie->getPath(),
    'domain'   => $cookie->getConfigDomain(),
    'secure'   => $cookie->isSecure(),
    'httponly' => $cookie->getHttponly()
);*/
$cookieParams = array();

This will allow you to log in. 3- Then go to admin panel check configuration, System->Configuration->web->session & cookie management in that the HTTP control set from Yes to No. Clear or set the proper path.

Hope this answer will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.