I'm wroking with Magento 2.1.1 (with PHP 5.6) and when I try to run a bin/magento command I'm getting nothing. No error, no message, nothing.

I didn't found any special message on logs. Has anyone seen this problem before? There's some recomendation to try to debug this issue?

  • Barbanet, what was the sollution? Same problem here... Commented Nov 26, 2017 at 20:59
  • 2
    Try to add 'ini_set('display_errors', 1);' to bin/magento. Maybe you'll see some helpfull outputs.
    – alexblum
    Commented Apr 19, 2018 at 11:01
  • You should actually check error_log file on magento root which will give out errors for cli runtime errors. It was memory shortfall for me. Commented May 18, 2019 at 14:19
  • did you get a solution?
    – Mohit Rane
    Commented Aug 2, 2019 at 6:55
  • Hi @MohitRane I never was able to reproduce the issue but at that time, no other information was available. A super strange issue that was solved after an upgrade or a change of environment (I don't remember right now)
    – Barbanet
    Commented Aug 2, 2019 at 19:44

3 Answers 3


It indicates that the error is being triggered while executing the command but for some reason, the view is disabled to read.

Luckily, all errors of Command is getting recorded in "error_log" file situated at the root, open it and read you error to fix this on the permanent basis.

Thank You Zuber


Open bin/magento in your preferred file editor and add the following line and save:

ini_set('display_errors', 1); // allow PHP errors reporting Run the command again:

php bin/magento list

it will show error which the cause cli not run


Just bin/magento command will not work.

You can use commands like

php bin/magento setup:upgrade

Make sure you current directroy in you magento instance ( cd /var/www/magento/)

For more command reference's.

  • That isn't the problem. No matter in which way I execute the command, the result is the same. Also, you can run CLI commands with bin/magento because the file has the SheBang ( github.com/magento/magento2/blob/develop/bin/magento )
    – Barbanet
    Commented Sep 14, 2016 at 14:37
  • Ok fine, Make sure your php is running fine. type 'where is php', then you can get path like D:/something/php.exe... Then make the current directory in the exe (cd D:/something/php.exe /var/www/myapplication/bin/magento setup:upgrade. ) execute like. Commented Sep 14, 2016 at 14:53
  • If you execute bin/magento then it shows the list of available commands, so even this should work.
    – Black
    Commented Sep 8, 2021 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.