3

Top navigation menu not displaying in my Magento. I refreshed cache and made reindexing.

I followed many links and made all the possible options provided from the links. Still, it's not showing the menu.

I just have a main menu with a submenu, in the "All stores" already have associated the menu, but even so, the menu is not displayed.

2

checklist

Login to admin. In Product -> Categories click your category then check the below options are enable in General information tab

  1. Is Active -> YES
  2. Include in Navigation Menu -> YES

In Display Setting

  1. Is Anchor -> YES

All the categories should comes under default category

enter image description here

  • i have setting but no working the menu .not display in front end menu – jignesh Sep 14 '16 at 10:59
  • same that but not display menu – jignesh Sep 14 '16 at 11:10
  • check my updates. mostly you made mistake in category creation so cross check. – Bilal Usean Sep 14 '16 at 11:10
  • it is happen suddenly or from the beginning itself ? – Bilal Usean Sep 14 '16 at 11:14
  • thank it's work fine. – jignesh Sep 14 '16 at 11:21
0

I'm unsure if you were able to fix your issue, but this has fixed mine when it's been related to Varnish:

in default.xml

    <referenceBlock name="catalog.topnav" remove="true"/>
    <referenceBlock name="store.menu">
        <block class="Magento\Theme\Block\Html\Topmenu" name="catalog.topnav.fix" template="Magento_Theme::html/topmenu.phtml" before="-"/>
    </referenceBlock>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.