3

How do we get Magento 2.1.1 migration (from 1.8.1.0) to skip the checks below, so that we can move past these errors?

[2016-09-13 21:48:27][INFO][mode: data][stage: volume check][step: EAV Step]: started 100% [============================] Remaining Time: 1 sec [2016-09-13 21:48:27][ERROR]: Class catalog/product_attribute_backend_finishdate does not exist but mentioned in: eav_attribute.backend_model for attribute_id=78 [2016-09-13 21:48:27][ERROR]: Class ultramegamenu/category_attribute_source_block_proportions does not exist but mentioned in: eav_attribute.source_model for attribute_id=138 [2016-09-13 21:48:27][ERROR]: Class ultramegamenu/category_attribute_source_categorylabel does not exist but mentioned in: eav_attribute.source_model for attribute_id=141 [2016-09-13 21:48:27][ERROR]: Class seosuite/catalog_product_attribute_source_meta_robots does not exist but mentioned in: eav_attribute.source_model for attribute_id=142 [2016-09-13 21:48:27][ERROR]: Class seosuite/catalog_product_attribute_backend_meta_canonical does not exist but mentioned in: eav_attribute.backend_model for attribute_id=143 [2016-09-13 21:48:27][ERROR]: Class seosuite/catalog_product_attribute_source_meta_canonical does not exist but mentioned in: eav_attribute.source_model for attribute_id=143 [2016-09-13 21:48:27][ERROR]: Class seosuite/system_config_source_crossdomain does not exist but mentioned in: eav_attribute.source_model for attribute_id=144 [2016-09-13 21:48:27][ERROR]: Class seosuite/catalog_product_attribute_source_meta_robots does not exist but mentioned in: eav_attribute.source_model for attribute_id=146

1
  • Anyone able to help on this? Sep 15 '16 at 4:27
7

Use the class-map.xml to remap the classes. You can leave the <to> tag empty to simply ignore the class.

For example, add this to class-map.xml to ignore the class catalog/product_attribute_backend_finishdate:

<rename>
    <from>catalog/product_attribute_backend_finishdate</from>
    <to></to>
</rename>

See: https://github.com/magento/data-migration-tool/issues/144

2
  • 1
    hi @Lachlan i am getting error like below, Class tm_megamenu/system_config_source_cms_block does not exist but mentioned in: eav_attribute.source_model for attribute_id=140, how to fix it? Nov 22 '18 at 14:24
  • Similar issue Jafar, did you find a fix? Dec 17 '18 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.