4

For testing purpose I wanted to use Docker container with Magento Community Edition. I use alexcheng/magento2 from hub.docker.com. After configuration of database and successful installation of Magento every page inside this service is displaying me error screen.

There has been an error processing your request
Exception printing is disabled by default for security reasons.
Error log record number: 688248154740

In app folder I've found file with that number in ./var/report/ It contains message given below:

a:4:{i:0;s:2057:"Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory.
The following modules are outdated:
Magento_Theme schema: current version - 2.0.1, required version - 2.0.0
Magento_Theme data: current version - 2.0.1, required version - 2.0.0
Magento_Customer schema: current version - 2.0.7, required version - 2.0.6
Magento_Customer data: current version - 2.0.7, required version - 2.0.6
Magento_Cms schema: current version - 2.0.1, required version - 2.0.0
Magento_Cms data: current version - 2.0.1, required version - 2.0.0
Magento_Catalog schema: current version - 2.0.7, required version - 2.0.3
Magento_Catalog data: current version - 2.0.7, required version - 2.0.3
Magento_Search schema: current version - 2.0.4, required version - 2.0.1
Magento_Search data: current version - 2.0.4, required version - 2.0.1
Magento_Bundle schema: current version - 2.0.2, required version - 2.0.1
Magento_Bundle data: current version - 2.0.2, required version - 2.0.1
Magento_Downloadable schema: current version - 2.0.1, required version - 2.0.0
Magento_Downloadable data: current version - 2.0.1, required version - 2.0.0
Magento_Sales schema: current version - 2.0.3, required version - 2.0.1
Magento_Sales data: current version - 2.0.3, required version - 2.0.1
Magento_GroupedProduct schema: current version - 2.0.1, required version - 2.0.0
Magento_GroupedProduct data: current version - 2.0.1, required version - 2.0.0
Magento_CatalogRule schema: current version - 2.0.1, required version - 2.0.0
Magento_CatalogRule data: current version - 2.0.1, required version - 2.0.0
Magento_SalesRule schema: current version - 2.0.1, required version - 2.0.0
Magento_SalesRule data: current version - 2.0.1, required version - 2.0.0
Magento_Swatches schema: current version - 2.0.1, required version - 2.0.0
Magento_Swatches data: current version - 2.0.1, required version - 2.0.0
Magento_GiftMessage schema: current version - 2.0.1, required version - 2.0.0
Magento_GiftMessage data: current version - 2.0.1, required version - 2.0.0";i:1;s:905:"#0 [internal function]: Magento\Framework\Module\Plugin\DbStatusValidator->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#1 /var/www/html/lib/internal/Magento/Framework/Interception/Interceptor.php(142): call_user_func_array(Array, Array)
#2 /var/www/html/var/generation/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, Array)
#3 /var/www/html/lib/internal/Magento/Framework/App/Http.php(115): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#4 /var/www/html/lib/internal/Magento/Framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#5 /var/www/html/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#6 {main}";s:3:"url";s:7:"/admin/";s:11:"script_name";s:10:"/index.php";}

I've run bin/magento setup:upgrade and bin/magento setup:di:compile afterwards. Still I do not have access to Magento pages (including Admin panel).

How can I fix that?


Detailed info

Host distribution

Debian GNU/Linux 8
Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 GNU/Linux

Host MySQL version

mysql  Ver 14.14 Distrib 5.7.15, for Linux (x86_64) using  EditLine wrapper

Docker distribution

Ubuntu 14.04.3 LTS

Docker Magento version

Magento 2.0.9

Docker PHP version

PHP 7.0.6 (cli) (built: Aug 31 2016 21:32:11) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
1

You need to upgrade your database using command,

php bin/magento setup:upgrade

After run this command need to deployment,

php bin/magento setup:static-content:deploy

Remove Var folder from root and check again.

0

before doing this take a backup image of your container using below command

docker commit containerID/containerName  newImageName

let try this, in your log file it mention related to version mismatch in module.xml

The following modules are outdated: Magento_Theme schema: current version - 2.0.1, required version - 2.0.0

so please find outdated module list in setup_module table then delete that outdated module from that list. Then run the below command in magento root directory of your docker container it will update setup_module table.

php bin/magento setup:upgrade

I hope this will rectify your poblem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.