Maybe this is a bug in version 2.1

If I have e.g. 2 payment methods, after every payment method is the billing/shipping address shown (1 virtual item, so billing=shipping address).

So you would expect:

  • billing/shipping address
  • payment method 1
  • payment method 2

But I get:

  • payment method 1
  • billing/shipping address + order button
  • payment method 2
  • billing/shipping address + order button etc.

For other itemtypes the same situation, so payment method 1, billing address + order button, payment method 2, billing address + order button etc.

Any ideas ?

2 Answers 2


This is normal, but there is css to hide the sections that are not needed.

Are you including the standard magento css?

.checkout-payment-method .payment-method-content {
 display: none;
 padding: 0 0 20px 22px;

Plus other styles to show when active..

  • thanks these .css have been composed somewhere, that is all new for me and have to find out, in my case all have been shown ... I try now the default installation 2.1 with blank/luma theme to see if the problem is there too, there is nothing overwritten for this within my theme ..
    – Francois99
    Commented Sep 7, 2016 at 19:14
  • yes in the luma theme it is going right, so there must be changed something within my theme ..
    – Francois99
    Commented Sep 7, 2016 at 19:28
  • yes I fixed it for now, much style from styles-m.css (generated) was missing, but for now your piece of style and : .checkout-payment-method .payment-method._active .payment-method-content { display: block; } was enough to repair it for me, now I am going to contact the template maker ..
    – Francois99
    Commented Sep 7, 2016 at 23:05
  • Is it possible to disable the "billing and shipping address are the same" block in checkout? Commented Oct 20, 2016 at 22:03

Every payment method gets to decide whether or not to show a billing address form at all, and if so, includes its own copy of it. Only one (for the currently-selected payment method) should ever be shown at a time. This is how it's supposed to work.

  • thanks you are right so my problem is why they are all shown ...
    – Francois99
    Commented Sep 7, 2016 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.