2

Did a new Magento 2.1.1 CE install on a Hosted environment. All went well until the login into the Admin page. I get the message:

Your current session has been expired!

I tried several things. Like emptying the var/cash files and even the var/session files put in my .htaccess the lines:

php_value session.gc_maxlifetime 86400 
php_value session.cookie_lifetime 86400

Not working. When I look into the php settings I can see that these are (0) so the 86400 are not applied by the server (they do not provide such services for hosted sites).

Now what can I do to get into the back-end? I asked the provider to change the settings but I am not sure they are willing to do that. So is there another solution to get into the admin page?

  • Still not working. Which file can be altered making the cookie life-time temperarely be ingnored? Maybe that will make it possible to login? And make some changes in the settings in the BE to get it working? Better would be if Magento offers a patch or an updated version which covers this problem! – mr_typo3 Sep 8 '16 at 6:09
2

I had this issue and in my case it was incorrect time on MySQL server. You can check this by simply running this query:

select current_date(), current_time();
1

I had this problem with PHP version 7.0.9, an upgrade to PHP 7.0.11 solved the problem.

  • Might be a good solution. But In this case it is not going to work since the ISP is not supporting version 2.1.1. yet. Since it is a hosted environment. I ended up by installing version 2.0.9 instead. For now it seems to work. But would rather be on 2.1.1. – mr_typo3 Sep 23 '16 at 11:22
1

Same with PHP-7.0.7. Fixed after changing to PHP-5.6.19

0

I was getting the same error while adding the product right after magento 2.3.0 installation with sample database in my local system. I had just changed the 127.0.0.1 in DB which was localhost before and then I cleared/ flushed cache including indexing process through CMD and it works like it should be.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.