1

Until yesterday this website has been working properly. Strangely now when this url http://solankitextileagency.com is loaded, I'm getting this error

A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue

Script:http://solankitextileagency.com/js/lib/jquery/jquery-1.10.2.min.js

The order in which it is called in the page.xml is: 1.prototype/prototype.js 2.lib/jquery/jquery-1.10.2.min.js 3.lib/jquery/noconflict.js

Tried pretty much everything to debug, this issue has popped up all of a sudden. Was not there from the beginning. Any help/advice will be very much appreciated.

  • have you changed anything recently ? – Minesh Patel Sep 7 '16 at 6:04
  • I had installed this extension Mobile Assistant for Magento, even after installation the site was working fine. Only after a few hours the issue occurred. Since then I have deleted the extension and cleared the cache – Anith Sep 7 '16 at 7:02
  • it might be because of something goes in infinity loop in iteration OR calling something multiple time at once – Minesh Patel Sep 7 '16 at 7:06
1

Specially if for firefox.

Error happens when accessing certain websites

If the error happens only on a specific website, you can block scripts from running on that website. Many sites still function even if scripting is disabled.

Install the YesScript extension and restart Firefox.
Open the Firefox window, click the Tools menu and select Add-ons.
In the dialog that comes up, click on the YesScript entry.
Click Preferences.
In the YesScript Blacklist dialog, type the URL of the site that's giving you problems in the text box.
Click Add. The domain name of the site will be added to the list. 

Now that the problematic site has been blocked from running scripts, it will no longer cause unresponsive script warnings.

For ref:- https://support.mozilla.org/en-US/kb/warning-unresponsive-script

  • Thanks Arjun, but the issue is not just in firefox. Happening in chrome, safari etc. Error description is from firefox. – Anith Sep 7 '16 at 6:23
1

The issue was that one of the custom CMS block had content empty and the javascript was going into a loop like Minesh Patel said. Fixed it now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.