The full message is "Sorry, no quotes are available for this order at this time." but I see it in eleven locations in the source code! Where do I change it for my own custom message, I hope not in all the locations.

Although I'm not trying to change the language, I wonder if this is related to localization, and maybe there is only one place I need to make the change?

1 Answer 1


You can change translations for any language, this includes the default US English. There are two different ways to change core translations:

1. Using theme specific translations

You can define custom translations in your theme, create the following file if it does not exist yet:


(replace en_US if you use a different language)

Note that this should be a project specific theme, not rwd/default or some_bought_theme/default. If you did not already, you can add a child theme next to default and specify this one as theme in the system configuration. You don't need to copy anything from the default directory since Magento falls back automatically, so you only need to add the files that are customized.

In the translate.csv you can add your custom translations. Since the translated string is "Sorry, no quotes are available for this order at this time." and it's coming from the Mage_Sales module, you need to add this line:

"Mage_Sales::Sorry, no quotes are available for this order at this time.","your custom translation here"

2. Using the "inline translation" feature

As a store manager you can change translations using the "Inline Translation" feature.

Summarizing the documentation:

  1. Add Your IP Address to the Developer Mode Whitelist (System > Configuration > Developer)
  2. Disable Output Caches (System > Cache Management)
  3. Activate the Translate Inline Tool (System > Configuration > Developer)
  4. Update the Text (Click the book icon next to any text in the frontend that you want to change)
  5. Restore Original Settings

This will save the custom translation in the database for the selected store and theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.