1

I recently installed the current magento 2 version (fresh install) on an apache server. Everything worked as intended until I logged into the admin panel, which results in an internal server error. As my access to log-files is very limited due to hosting (domain factory) I hope that someone could just throw a few possible solutions at me which I could try out to solve the issue. .htaccess file is the original one (magento 2 installed via composer).

Roundup:

  • Apache Webserver with php7.0.6
  • Fresh Magento 2 install via composer
  • original .htaccess
  • Frontend works fine, Admin-Login page too - but after login getting error 500
  • Webhoster is domain factory (which limits access to log-files i.e. no access to apache logfiles via terminal)
  • already tried developer mode and rebuilding static content, clearing cache
0

I have the same issue. I had checked the apache configuration and edited the following:

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

then restart apache.

| improve this answer | |
0

My webhoster was able to give me access to a correct error.log file, sadly only for php5.6 (which the domain is running now). On php5.6 the error was solved by deactivating asp_tags for php.

Seems to be the same error solved in: When i login the backend of magento2 have a Fatal error

KAndy said that asp tags were removed in php7, but they're still in the php.ini configurator (sadly I don't have access to the direct file), disabling them worked on php7 too.

(so the domain is now running php7 again.)

But anyway - thanks for the help!

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.