0

This is Magento 1.9.2.4. Here is the current situation:

  1. Server time is correctly set up. I can check it from Terminal.
  2. PHP time is correctly set up as timezone. I created a php file for showing the date.
  3. Time for Magento frontend is correctly set up. I can check it in any phtml template.
  4. In Magento database time for Created At and Updated At fields are UTC time

Here is my issue:

In Magento file system all changes to files or folder show a time one hour after system time. I deleted the files in /var/cache then reload the frontend and current system time/Magento is 14:42 and files were created 15:42. "Someone" is adding one hour to every file/folder created or changed. I uploaded a product image again 1 hour after system time.

Does anyone have a solution for this?

0

Solved. This issue is coming from WinSCP. If you get this issue use this solution: in "Login" window after filling up all your server information click on [Advanced ...] button. In "Advanced Site Settings" window click on Environment and in section "Daylight saving time" choose "Preserve remote timestamp". Now login to your server and dates should be listed correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.