0

Yesterday a client of mine on Magento Community had all of their media from the /media/wysiwyg/ directory deleted. We assumed human error. Then today, another client on Magento Enterprise had the same thing happen. These are hosted on different servers, on different accounts, with different Magento versions. It's quite the coincidence, so I'm concerned that something sinister might be happening here, such as an unpatched vulnerability.

If you look at the Insert Image... screen on CMS pages, there isn't a way to delete the entire contents of the "Storage Root" folder. So I'm not actually sure how an Admin could have even accidentally deleted the entire contents of this directory without going folder to folder and deleting each one.

Have any of you seen this happen before?

0

Please change this setting and check

Admin->System->Configuration->General(Content Management)->WYSIWYG Options->Use Static URLs for Media Content in WYSIWYG for Catalog

Change this to "Yes".

  • Can you explain how this affects the issue at hand? The missing images are actually missing from the file system, and not related to a base domain change. – Tyler V. Sep 3 '16 at 5:13
  • It will not get the missing image. It will hold the image for next time other wise every time wysiwyg miss the image after some time. – Ashish Jagnani Sep 3 '16 at 5:24
  • I'm sorry. I don't understand. – Tyler V. Sep 3 '16 at 6:31
  • You cant recover the missing images, but next time it will not delete the images from wysing folder. – Ashish Jagnani Sep 3 '16 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.