3

am attempting to use the built-in Magento contact form. I have enabled the contact form in the configuration as well as set all email addresses. I have login enabled. When I use the form it redirects and states that the email has been sent successfully. No errors are present in log files. The php_mail.log shows the emails being sent. A cron job is set up and enabled. I can't figure out why I am not receiving emails from the contact form? Any help is appreciated. Magento 1.9.2.

4 Answers 4

0

I had this same issue: No errors, Success pop up message. but i'd never receive the email...

In my case, i forgot to configure the SMTPPro module in Magento Admin Painel:
System -> Configuration -> Aschroder Extensions -> SMTP Pro -> General Config.

Custom SMTP
Login
[email protected]
passw**d
smtp.server.com
port 587
No SSL

If you don't use this module, this info might be useful too:

http://www.serversmtp.com/en/smtp-magento-settings

0

Try with default email sending by PHP code on that same email id and check it's working or not. It may be the issue of that email id or maybe the server issue. If it's a server issue then you can use SMTP to send the email.

0

Do you have tried with the default PHP code to send emails? If not then please try it out first and check the mail is sending or not. It may be an issue with the e-mail id or the server issue. The alternate option is, You can use SMTP to send emails on Magento. There are several free SMTP extensions available in the market. You can download and install it.

0

For that, you need to install and configure SMTP extension and check it.

Extension link : https://www.mageplaza.com/magento-2-smtp/

Configuration link : https://www.mageplaza.com/blog/how-to-configure-mailcom-smtp-in-magento-2.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.