0

I'm quite new to Magento so any help is welcome.

I'm using Magento V1.9.1.

I'm having an issue loading the home page of the site. The default page is set under System > Configuration > Web > Default Pages in the admin and the page has content in the CMS -> Pages section. The home page shows the header and footer but there is no content.

I've tried creating a new test page and setting this as a default home page and this still shows a blank content area.

If I go to /index.php or /home, the page loads exactly as expected, leading me to believe it is a routing issue. Changing the default home page does change the output of the /index.php URL.

EDIT 2: I've tested the same set of files, with the same local.xml files on my local server and the home page loads correctly, which rules out the layout being defined incorrectly (I think).

EDIT: Adding screenshots as requested. I've had to obscure certain parts of the website for privacy reasons.

This is the home page of the site without the index.php path. The content should appear in the dashed area, between the header and footer. Home page without path

With the index.php path, the content appears correctly. Home page with path

The settings in the System > Configuration > Web > Default Pages Magento System settings

And the page in the CMS -> Pages section. Home page information Home page content

Any help is appreciated.

0

if it for your learning purpose and in your local machine then disable magento cache shown in below url

https://docs.nexcess.net/article/how-to-disable-caching-within-magento.html

Otherwise refresh cache and try again and let me know if you still find same issue.

  • I've refreshed cache by deleting the contents of the var/cache folder and using the Magento Admin panel, and there is no change. – Adam Taylor Aug 31 '16 at 7:48
  • can you provide screenshot what you actually doing – Murtuza Zabuawala Aug 31 '16 at 8:11
  • Thanks for your help. I've edited the question with relevant screenshots now. – Adam Taylor Aug 31 '16 at 8:51
  • I've also just added a bit of information that the same setup, and same local.xml file, works on my local server, which rules out the layout being defined incorrectly. Thanks again! – Adam Taylor Aug 31 '16 at 9:09
0

Found the issue finally.

There was an include 'ezzoom.php' line added to the index.php file, which was causing an aggressive caching of all pages.

Removing this solved the home page and made it load correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.