1

I am facing a problem with new order emails with magento. I am working on Website Link and I am facing a problem when any customer place a order the order confirmation emails not working and emails are not received by customer and website admin. AOE Scheduler is already configured on the website and there are no errors in the error log. Please assist me to fix this issue. I have already search almost everything on google.

  • is other emails are working ? like contact us , forget password emails, also check in spam once.... – Baby in Magento Aug 24 '16 at 9:25
  • Thank You @BabyinMagento, contact us emails are working. But only order emails are not working. Now website is also stopped working :( – Sanchit Gupta Aug 24 '16 at 9:29
  • Stoped woking means please explain.... also what chnages you done recently ? – Baby in Magento Aug 24 '16 at 9:30
  • I was looking for the solution on google, try to figure out the issue but no success and I have revert all changes. – Sanchit Gupta Aug 24 '16 at 9:35
  • okay is site working now ? – Baby in Magento Aug 24 '16 at 9:36
1

For your website break you have added some extra space starting or at the end of any file that you have created.

please check and solve that issue first

For Order Email from 1.9.1 onwards order emails were sent via cronjob So be sure you have configured cron.sh file in cronjob

And if you want to overcome with cronjob you can install Below extension

https://www.magentocommerce.com/magento-connect/smtp-pro-email-free-custom-smtp-email.html

This extension allow you to create custom smtp and you will overcome queue issue with this extension setting

Hope this solution will help you.

|improve this answer|||||
  • Ok check and let me know – Murtuza Zabuawala Aug 24 '16 at 10:01
  • Have You check this are the things? – Murtuza Zabuawala Aug 25 '16 at 6:46
  • Hello @murtuza, Website is working now. But issue is still same – Sanchit Gupta Aug 25 '16 at 6:51
  • Have you install that extension? – Murtuza Zabuawala Aug 25 '16 at 6:52
  • Not yet. Should I remove AOE_SCHEDULER first ? – Sanchit Gupta Aug 25 '16 at 6:52
0

One thing to check is that your email queue is not stuck.

There are 2 tables in the database core_email_queue and core_email_recipients.

  • core_email_queue contains all the emails to be sent.
  • core_email_recipients contains who to send those emails to.

If there is an email in core_email_queue without a corresponding recipient in core_email_recipients then that email cannot be sent. This stops the rest of the queue being processed.

If this is the case just delete the offening email from core_email_queue and the rest of the email queue will be sent the next time the cron is run.

|improve this answer|||||
0

1) For the website error it seems you have edited an xml file and left it with some text or unclosed tag.

2) For skipping cron others already have suggested for the smtp pro extension, Make sure you have provided proper permissions to the email used in smtp especially for gmail.

3) Check by sending email from php mail function. if it sends the test message then confirm your order email template is proper.

4) In case you are already have done above things then also try this: navigate to admin -> system -> configuration -> sales emails. In order section change order email copy method from bcc to separate email and check if there are multiple emails then check those comma separated values are not having spaces between them like email1, email2 if it is so try making it email1,email2

|improve this answer|||||
0

PROBLEM FIXED Same problem started for us 30 hours ago since an automated Cpanel update to version 58 build 24. What we found was AOE crons stopped running exactly the time of the Cpanel Update. We use AOE Scheduler to schedule the send of emails etc.

What fixed it for us was to recompile Apache and AOE crons began working again, all old queued emails were sent so i don't recommend deleting any database tables.

I don't think this is a Magento or AOE Scheduler issue just that the host needed to have Apache Recompiled. If you have access to your host go to WHM > Easy Apache > (We use Easy Apache 4) click Update System. In 5 mins it is working again. If you don't have access to your Host Root, as your hosting provider to recompile Apache and you should be right.

|improve this answer|||||
  • I should add that before i recompiled Apache i cleared out all of the old failed tasks in AOE Scheduler System > Scheduler > List View > Select All > Delete. Then regenerated the schedule in Timeline View. Recompiled and they started turning green again. :) – Jason Keys Aug 26 '16 at 1:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.