0

I have tried to run the command line script in a linux VPS with PuTTy and get this error:

Magento supports PHP 5.6, 7.0.2, and 7.0.6 or later. Please read http://devdocs.magento.com/guides/v1.0/install-gde/system-requirements.

I tried to update php to 7.0.5 but

  • phpinfo() shows 7.0.5
  • in PuTTy php -v shows php version 5.4.1

How to run command-line in my VPS?

0
  1. You have installed multiple versions of PHP and PHP-CLI uses a different version than the web server. Run which php to see to which executable "php" refers. How to change that depends on your operation system and how you installed PHP in the first place. But you can always use the PHP 7 binary directly, for example with /usr/local/bin/php7. For the real path, look at the phpinfo() output of your info.php.
  2. Updating to PHP 7.0.5 would not help anyways. As you see in the error message, 7.0.3 to 7.0.5 are not supported, so if you use PHP 7, you should update to the latest version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.