0

I have SSL enabled in my site, here is what I was expecting: SSL only on checkout process, customer restrict area and backend, not on the entire store such as product and category pages.

In my settings I have both options:

  • Use Secure URLs on Storefront: YES
  • Use Secure URLs in Admin: YES

The Storefront option if changed to NO, the checkout and customer restrict area doesn't work with SSL.

Is there any way to set the store to work as expected?

Thank you.

  • Can you explain why you wouldn't want SSL across the whole site? I can't think of anything positive of doing your way however there are plenty of positives if you SSL the whole site – Goose84 Aug 22 '16 at 19:59
  • SSL is slower than regular protocol. But also is creating duplicated content, because the canonical shows with http and with https. – BrunoBueno Aug 22 '16 at 20:01
  • Do you have your base url with or without https – Goose84 Aug 22 '16 at 20:17
  • Also with keep alive setting turn on ye security benefits of having SSL across the whole site should out weigh your speed concerns – Goose84 Aug 22 '16 at 20:19
  • base url without https – BrunoBueno Aug 22 '16 at 20:53
0

I believe that by now you have realized that it is better to serve all your web pages over HTTPS, instead of HTTP. Furthermore, HTTPS is the new Web Standard now and web content served over HTTP will be treated as a website flaw.

So, it is recommended to enable HTTPS redirect and full-page SSL for your Magento website.

From Stores > Configuration > Web for Base URL add the HTTPS version of your domain. Then, set Use Secure URLs on Storefront, set Use Secure URLs on Admin and Upgrade Insecure Requests to YES.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.