1

I have a strange issue with Magento 2.0.7 - 2.1.0 versions in my vps. When I try to create multiple options (more than 30 variations of color and sizes), it gives me "No data to save" error while trying to save the product. If I create a product with only around 10 child products for a configurable product, it does not give me any error. Attached are the error screenshot and my server's php.ini settings. This vps has 8gb of ram and enough ssd space. Please hint me something I am missing. I tried to increase several php configuration settings max_input_vars, opcache.max_accelerated_files etc. Nothing helped. It seems something related to session. But not sure what it is.enter image description here

2
  • I'd be glad if any one can give me some idea to solve it
    – rbncha
    Aug 31, 2016 at 7:20
  • i have the same error with all product types. Could you solve this problem?
    – jamie
    May 25, 2018 at 15:49

1 Answer 1

0

For anyone who still has this problem, we had an issue where the server configuration forced a trailing slash behind all URL's. This forced a redirect which resulted in a faulty request and caused this issue. When we commented the rewrite rule in the nginx settings the we could save the products.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.