1

I receive an error when I want to update my products.

I got the following error;

SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction

query was:

DELETE FROM `catalog_product_entity_int` 

WHERE (attribute_id = '96') AND (entity_id = '55844') AND (store_id <> 0)

How can I solve this?

After setting innodb_lock_wait_timeout to 120, I get the following error report from Magento:

a:5:{i:0;s:41:"SQLSTATE[HY000] [2002] Connection refused";i:1;s:1777:"#0 /public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(111): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(396): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /public_html/lib/Zend/Db/Adapter/Abstract.php(460): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 //public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(504): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 /public_html/app/code/core/Mage/Core/Model/Resource.php(179): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 /public_html/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Array)
#7 /public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(141): Mage_Core_Model_Resource->getConnection('core_setup')
#8 /public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(234): Mage_Core_Model_Resource_Setup->__construct('core_setup')
#9 /public_html/app/code/core/Mage/Core/Model/App.php(428): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#10 /public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Model_App->_initModules()
#11 /public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#12 /public_html/index.php(83): Mage::run('', 'store')
#13 {main}";s:3:"url";s:85:"/index.php/admin/catalog_product/index/store/0/key/83a8e99002e7976f0d262a923a214f92/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}
1

The easy fix is to restart mysql service in hosting admin.

If that doesn't work then run this statement via phpMyAdmin :

SET innodb_lock_wait_timeout = 120;

  • Just delete "maintenance.flag" in /root and restart mysql services – Manashvi Birla Aug 16 '16 at 7:25
0

Look at this:

http://www.elevateweb.co.uk/magento-ecommerce/magento-error-sqlstatehy000-general-error-1205-lock-wait-timeout-exceeded

If you have some problem in your code (you propably have) you can kill the lock manually logging into mysql terminal, but if it's caused by your code you should fix that issues, because the problem will not disappear for good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.