0

someone else installed an instance of Magento for me on Ubuntu on AWS and now I am running into some permission issues and trying to debug (e.g. database tables are not being created). I think the permission issues are because on this server the DB is installed on RDS. I have the exact Magento installed on another AWS server with DB locally installed and that's working fine.

  1. How do I check which user is Magento running as?
  2. How can I manually login into MySql from command prompt? Just typing "MySql" gives the error "ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)". I can see MySql credentials at app/etc/local.xml, but unable to figure out how to get the "mysql>" prompt
  3. Any pointer on what the issue (permission issues) be MySql@RDS?

Thanks!!

0
  1. You should check if you have enabled access from your server to RDS
  2. mysql -hyour_rds_url -uusername -ppassword

Please try it and update me

0

1 - see your app/etc/local.xml and check RDS instance page, you will see the user name.

2 - create a file .my.cnf like this:

[client]
host=rds.database.end.point.url
user=user.name
password=pass.word

3 - check if security groups configured. you can allow access to your database port, VPC, or even make it public. http://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/CHAP_SettingUp.html

0

1) Your root user is not available to you (by default) in AWS RDS. You need to use the user that was created for that database.

2) You should confirm that you have the appropriate security open from RDS -> EC2

3) You will need a firewall port open for 3306 for no.2

4) You can test using the following command (in terminal)

mysql -uuser -p'password' -hyour_rds_host_address

5) Once you have confirmed the above you can put those values from no.4 in your app/etc/local.xml

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.